Actively exploited

CVE-2025-24813 Apache Tomcat Path Equivalence Vulnerability

Apache Tomcat contains a path equivalence vulnerability that allows a remote attacker to execute code, disclose information, or inject malicious content via a partial PUT request. This vulnerability can be chained with CVE‑2026‑34486.

From the CISA KEV catalogue version 2026.11.06, with Cybergen analysis. Updated 6 Nov 2026.

Our Assessment

Should You Worry?

Patch nowCybergen assessment
  • CISA confirmed exploitation in the wild and added it to the Known Exploited Vulnerabilities catalogue on 1 Apr 2025.
  • Rated Critical severity (CVSS 10.0, scored by CISA).
  • It has been in the catalogue for 584 days. Systems still unpatched now have almost certainly been scanned for it.
The Vulnerability

What It Is

Path Equivalence: 'file.Name' (Internal Dot) leading to Remote Code Execution and/or Information disclosure and/or malicious content added to uploaded files via write enabled Default Servlet in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.2, from 10.1.0-M1 through 10.1.34, from 9.0.0.M1 through 9.0.98. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected. If all of the following were true, a malicious user was able to view security sensitive files and/or inject content into those files: - writes enabled for the default servlet (disabled by default) - support for partial PUT (enabled by default) - a target URL for security sensitive uploads that was a sub-directory of a target URL for public uploads - attacker knowledge of the names of security sensitive files being uploaded - the security sensitive files also being uploaded via partial PUT If all of the following were true, a malicious user was able to perform remote code execution: - writes enabled for the default servlet (disabled by default) - support for partial PUT (enabled by default) - application was using Tomcat's file based session persistence with the default storage location - application included a library that may be leveraged in a deserialization attack Users are recommended to upgrade to version 11.0.3, 10.1.35 or 9.0.99, which fixes the issue.

Affected Versions

ProductVersions
Apache Software Foundation Apache Tomcat11.0.0-M1 to 11.0.2
10.1.0-M1 to 10.1.34
9.0.0.M1 to 9.0.98
8.5.0 to 8.5.100

From the public CVE record, as supplied by the vendor. Always confirm against the vendor advisory.

From Watch to Action

What To Do Now

  1. 1

    Find it

    Search your asset inventory and external attack surface for Apache Tomcat. Include cloud images, appliances and anything a supplier runs for you.

    Attack Surface Management
  2. 2

    Fix it

    Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.

    Vulnerability Management
  3. 3

    Hunt for compromise

    If an affected system was reachable before you patched, assume it may have been hit. Check logs, new accounts, web shells and outbound connections from the date of exposure.

    Incident Response
  4. 4

    Prove it is fixed

    Rescan or test the system after patching. Upgrades that fail silently and forgotten secondary instances are common.

    Penetration Testing

Not Sure If You Are Exposed?

Our attack surface and vulnerability teams can check your internet-facing estate for CVE-2025-24813 and every other exploited flaw on the list.

Check My Exposure