CVE-2020-11023 JQuery Cross-Site Scripting (XSS) Vulnerability
JQuery contains a persistent cross-site scripting (XSS) vulnerability. When passing maliciously formed, untrusted input enclosed in HTML tags, JQuery's DOM manipulators can execute untrusted code in the context of the user's browser.
From the CISA KEV catalogue version 2026.11.06, with Cybergen analysis. Updated 6 Nov 2026.
Should You Worry?
- CISA confirmed exploitation in the wild and added it to the Known Exploited Vulnerabilities catalogue on 23 Jan 2025.
- Rated Medium severity (CVSS 6.9, scored by Vendor).
- It has been in the catalogue for 652 days. Systems still unpatched now have almost certainly been scanned for it.
What It Is
In jQuery versions greater than or equal to 1.0.3 and before 3.5.0, passing HTML containing <option> elements from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.
Affected Versions
| Product | Versions |
|---|---|
| jquery jQuery | >= 1.0.3, < 3.5.0 |
From the public CVE record, as supplied by the vendor. Always confirm against the vendor advisory.
What To Do Now
- 1
Find it
Search your asset inventory and external attack surface for JQuery. Include cloud images, appliances and anything a supplier runs for you.
Attack Surface Management - 2
Fix it
Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.
Vulnerability Management - 3
Hunt for compromise
If an affected system was reachable before you patched, assume it may have been hit. Check logs, new accounts, web shells and outbound connections from the date of exposure.
Incident Response - 4
Prove it is fixed
Rescan or test the system after patching. Upgrades that fail silently and forgotten secondary instances are common.
Penetration Testing
The Compliance Clock
General guidance, not legal advice. Your obligations depend on your sector, scope and jurisdiction.
More Exploited JQuery Flaws
Not Sure If You Are Exposed?
Our attack surface and vulnerability teams can check your internet-facing estate for CVE-2020-11023 and every other exploited flaw on the list.
Sources
- CISA Known Exploited Vulnerabilities catalogue
- NVD: CVE-2020-11023
- CVE record: CVE-2020-11023
- FIRST EPSS
- blog.jquery.com/2020/04/10/jquery-3-5-0-released/
- debian.org/security/2020/dsa-4693
- lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/QPN2L2XVQGU
- oracle.com/security-alerts/cpujul2020.html
- jquery.com/upgrade-guide/3.5/
- security.netapp.com/advisory/ntap-20200511-0006/
- drupal.org/sa-core-2020-002
- github.com/jquery/jquery/security/advisories/GHSA-jpcq-cgw6-v4j6
